Visit our BAC Favorite Places Web Page

Author Topic: Electronic Speedo  (Read 288 times)

Mark Beavin

  • BAC Member
  • *
  • Posts: 39
  • Thanked: 1 times
  • 602-448-1434
Electronic Speedo
« on: January 15, 2019, 10:49:10 AM »
Has anyone repaired their electronic speedometer?  Mine starts out a 0 and as soon as I roll it sweeps all the way around and stays there until I turn the ignition off. The odometer part works fine so I'm sure the sensor is fine where ever that is located. Been using a MPH app on my phone but would like to fix the original gauge.
Mark Beavin  Judi Binderman
FMC 491464
1996 Beaver Monterey 30'
3126 Cat Diesel 250 HP

Mike Shumack

  • BAC Member
  • *
  • Posts: 942
  • Thanked: 231 times
  • Orlando, Florida
Re: Electronic Speedo
« Reply #1 on: January 17, 2019, 11:13:34 AM »
Mark, there are shops that rebuild speedometers. Yours appears to made by Spartan (according to info at the Beaver Coach Assist). But I would check the connections before doing anything with the speedo itself.

I don't know how your speedometer is connected but I would think there has to be receiving info from the transmission output sensor. I would check that area (transmission) to be sure there are not any loose or chaffing wires - then same at the back of the speedometer. I don't know that having the odometer working means the wiring/sensor is good and speedometer itself is therefore bad. If you contact a shop that rebuilds these, they may be able to give you some troubleshooting advice.

Googling the manufacture of your speedo didn't come up with anything - except some links to rebuilders and this link (maybe to purchase a used one)
 Such as (this is example, I don't not know anything about this company) https://www.instrumentclusters.com/

The screenshot below came from the "96 Monterey Dwgs" parts list at the Coach Assist section but I'm not sure you can trust the info 100% so if you can get to back of the speedometer, try to verify the manufacture and model of speedometer. http://beaveramb.org/coach-assist-members-only-new/

Here is a link to a thread that might help if you need to replace your Speedometer http://beaveramb.org/forum/index.php?topic=143.0

Lastly, there are some RV salvage yards that may have what you need. Such as https://rvcomponents.visonerv.com/cgi-bin/f/motorhomecluster-gauges.pl
« Last Edit: January 17, 2019, 01:10:11 PM by Mike Shumack »
- Mike

'05 Beaver Patriot Thunder, Vicksburg, CAT C13  525HP, Allison 4000MH, HydraLift
The following users thanked this post: Mark Beavin

Mark Beavin

  • BAC Member
  • *
  • Posts: 39
  • Thanked: 1 times
  • 602-448-1434
Re: Electronic Speedo
« Reply #2 on: January 17, 2019, 04:08:20 PM »
Mike,
  I was told to check the speed sensor at the output of the tranny. The plug was wet with tranny fluid inside. I cleaned it with electronic cleaner and it did not help. Must be a seal that is out on that sensor so it needs replacing anyways. Maybe that will do it.
Mark Beavin  Judi Binderman
FMC 491464
1996 Beaver Monterey 30'
3126 Cat Diesel 250 HP