Visit our BAC Favorite Places Web Page

Author Topic: No oil pressure on silverleaf  (Read 235 times)

Daniel McShane

  • BAC Member
  • *
  • Posts: 20
No oil pressure on silverleaf
« on: May 18, 2019, 02:00:40 AM »
With the help of my son-in-law I finally have my Silverleaf Pc up and running. Everything seems to be working but oil pressure shows "0" with the engine running and dash gage bounces around as it has since I bought the coach. I do realize the motor won't run without oil pressure as its needed for the injectors. Is there a pressure switch strictly for indication? Thanks in advance.
1999 Monterey Trinidad 30 ft
Cat 3126b
2009 Jeep Wrangler toad

Steve Huber Co-Admin

  • Administrator Group
  • *
  • Posts: 2215
  • Thanked: 1300 times
Re: No oil pressure on silverleaf
« Reply #1 on: May 18, 2019, 03:02:09 AM »
Steve
2015-          07 Contessa Bayshore C9,  400 hp
2013-2015: 00 Marquis Tourmaline, C12, 425 hp
2005-2013: 01 Contessa Naples, 3126B, 330 hp

Daniel McShane

  • BAC Member
  • *
  • Posts: 20
Re: No oil pressure on silverleaf
« Reply #2 on: May 18, 2019, 11:26:00 AM »
Thanks Steve.
1999 Monterey Trinidad 30 ft
Cat 3126b
2009 Jeep Wrangler toad

Mike Shumack

  • BAC Member
  • *
  • Posts: 1047
  • Thanked: 266 times
  • Orlando, Florida
Re: No oil pressure on silverleaf
« Reply #3 on: May 18, 2019, 01:21:03 PM »
As said - here's the oil pressure sensor for 3126. Located next to ECM on filter side of engine.
The Silverleaf and ScanGauge get their readings from the ECM data, so there should be a "fault code" (engine check light) On if your oil pressure is out of specs. The dash gauge typically uses it's own sensor. But I believe you said the dash gauge and the Silverleaf are reading incorrectly (different sensors) - so I would definitely put a mechanical oil pressure gauge on the engine ASAP and confirm you have good pressure.

« Last Edit: May 18, 2019, 01:28:29 PM by Mike Shumack »
- Mike

'05 Beaver Patriot Thunder, Vicksburg, CAT C13  525HP, Allison 4000MH, HydraLift

Steve Huber Co-Admin

  • Administrator Group
  • *
  • Posts: 2215
  • Thanked: 1300 times
Re: No oil pressure on silverleaf
« Reply #4 on: May 18, 2019, 01:38:36 PM »
Dan,
Suggest you check the connections on the back of the dash gauge.
Steve
Steve
2015-          07 Contessa Bayshore C9,  400 hp
2013-2015: 00 Marquis Tourmaline, C12, 425 hp
2005-2013: 01 Contessa Naples, 3126B, 330 hp