Recent Posts

Pages: [1] 2 3 ... 10
1
Technical Support / Re: 2000 Patriot Dash Fan Resistor
« Last post by John Demartini on Today at 05:53:21 PM »
Thanks Eric. I’ll make sure to check connectors for  fan, resistor and switch.
2
Technical Support / Re: 2000 Patriot Dash Fan Resistor
« Last post by Eric Maclean on Today at 03:33:33 PM »
John
The blower resistor is a Ford #D8BH-19A706-AB
Just ask you local parts store NAPA (etc) for a blower resistor for a 1980 Ford F100 with Air conditioning.
Or a Standard Motor Products # RU-439

While you at it check the plug for burnt connectors

Hope this helps
Eric
3
Technical Support / 2000 Patriot Dash Fan Resistor
« Last post by John Demartini on Today at 01:52:27 PM »
Hello fellow Beaver owners.  My dash fan is operating only on high, I'm assuming the resistor is bad.  I located the resistor under the front cover close to the steering box area.  I unplugged the resistor and the fan operated the same, only on high.  Does anyone know of a source for a replacement?

Thanks for any suggestions or advice offered.
5
Technical Support / Re: SCS básement air
« Last post by Steve Huber Co-Admin on June 15, 2024, 10:32:44 PM »
Be sure to check the connector on the PCB. Overheating is a know problem. Also the service manual in Coach Assist has a troubleshooting guide.
Steve
6
Technical Support / Re: SCS básement air
« Last post by Duane Kunze on June 15, 2024, 09:35:12 PM »
Thanks for the reply Steve, I just saw this response, have been very busy with other things. I’m glad to know which is which. Looks like I may have a bad compressor.
7
Technical Support / Re: Air Solenoid and Fuel Line Replacement
« Last post by Scott Shearer on June 15, 2024, 02:44:44 AM »
Where are you taking it in Eugene?

-Scott
8
Technical Support / Re: Odometer Not Working
« Last post by Trige Gleim on June 15, 2024, 02:20:13 AM »
I just turned off and then back on the battery disconnects for a short time and now the odometer is reading correctly. Hope it continues to work  :D
9
Technical Support / Odometer Not Working
« Last post by Trige Gleim on June 15, 2024, 01:57:17 AM »
The odometer has stopped working. Attached is a picture of what the display looks like. All other gauges on the instrument panel are working. Any ideas on what to do? Thank you.
10
Technical Support / Re: Touch-up paint????
« Last post by Rick Vyncke on June 14, 2024, 11:25:56 PM »
Great information David!   Much appreciated.  Thanks
Pages: [1] 2 3 ... 10