Author Topic: 2005 Cat 400 Santiam  (Read 7209 times)

Michael McCue

  • Guest
2005 Cat 400 Santiam
« on: November 11, 2008, 04:33:10 PM »
Has anyone had a problem with the air intake for the Cat 400 powered Beavers? My air filter condition gage showed that the filter was restricted. I replaced the filter with a new one with no change. If I disconnect the intake hose that runs up the left side of the coach to the air inlet located up high on the left side the gage shows no restriction. The hose has no kinks or internal restrictions. Thanks for any help you can provide.

Richard And Babs Ames

  • Guest
Re: 2005 Cat 400 Santiam
« Reply #1 on: November 11, 2008, 06:51:34 PM »
Did you reset the restriction indicator? The gauge has to be reset by pushing on the bottom of indicator. I know this is a normal  but just want to be sure.

Phil Sales

  • Guest
Re: 2005 Cat 400 Santiam
« Reply #2 on: November 12, 2008, 01:20:42 AM »
On my '96 Patriot, I realized the supply hose was 5" and the intake plenum and the filter were set up for 7". There were reducers at both ends. I tossed the reducers and installed 7" hose. It made a 10 point difference on the restriction gauge. Heres hoping you have room and cash to do the same. Spartin uses a 7" hose and I got mine from a local Firetruck repair. Best of luck Phil

JimLNichols

  • Guest
Re: 2005 Cat 400 Santiam
« Reply #3 on: February 14, 2009, 05:52:29 AM »
05 monterey 400 c9  Had same restriction problem and installed an AFE oil coated filter with no change.  Had a sheet metal tech run the numbers on the air flow and he thought I could do better. He removed the 7" flex intake and built new from left side factory intake to the AFE air cleaner on right. He almost doubled my cfm. Also my mileage went from 6.8 to 7.8
   Jim  Nichols