Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Technical Support / 2006 Thunder
« Last post by Paul Champagne on June 14, 2024, 06:06:52 PM »
Hello my porch light has gone out and it is not the lamp can't find where the fuse is located the step and handle light work just the porch light is not?

Thanks

Paul
22
For all pictures and details please "click" on this link OR copy and paste this link into your browser:
https://heidilee.net/beaver-contessa/


For Sale: $85K or best offer
Coach located in Yucaipa CA 92399 Closest airport is Ontario, CA
California registration and clear title in hand.
ALL service and maintenance has been performed within the last 3000 miles.
Coach is mechanically sound and can be driven from coast to coast without a second thought.
Larry (949) 422-6018
23
Update: Slides fixed! The problem turned out to be a slipped bushing on one of my rail rollers. $9 spent on brass and stainless washers so it never happens again and slides function perfectly again.
24
General Discussion / Re: 2006 Monterey Laguna 4
« Last post by Mark Hoovler on June 14, 2024, 04:10:52 AM »
Thank you form the help
much appreciated

Mark
25
General Discussion / Re: 2006 Monterey Laguna 4
« Last post by Steve Huber Co-Admin on June 14, 2024, 02:35:48 AM »
06 Monterey wiring diagrams are on Coach Assist. Go to BAC Website, Coach Assist is under the Technical tab.
Steve
26
General Discussion / 2006 Monterey Laguna 4
« Last post by Mark Hoovler on June 14, 2024, 01:19:14 AM »
Looking for a wiring schematic for the 06 Beaver?  Is there a good place to find one?
Chasing a short in the Bay light circuit.

Thanks
27
AWSOME information Eric and Scott!

Scott The owner and I trouble shot it together yesterday and we came up with a switch power to the ECM as an additional connection so if it dropped from the boards the ECM would stay hot and not drop out. Your post helped me walk through the issues and they almost perfectly matched and he was going to check that board out and get back to me.
I am going out of town, so they are going to shut everything off and let it cool down and drain power from the boards and then see if they can get the problem to duplicate so they can positively identify the failure. Also, the generator may have just help with additional power but, we were also pushing on that switch trying to get it to run and it may have just made the connection.
I will update you all late next week. 
I will be happy to buy you both a cold one for this!!!
28
Technical Support / Re: Air Solenoid and Fuel Line Replacement
« Last post by Dan Johnson on June 13, 2024, 11:14:06 PM »
Search the forum for "fuel line leak"  I think Dave talks about the line from the primary filter to the transfer pump. Some break down inside. I updated the primary filter to Cat and changed the line to the pump. I would have to say getting rid of the Racor filter made a quieter running motor.
29
Technical Support / Re: C-9 Flames out at low speeds
« Last post by Steve Huber Co-Admin on June 13, 2024, 09:44:33 PM »
Input from Dave Atherton; First check the key ring weight as significant weight can cause the ignition switch to intermittently fail and cut power to the ECM. There is a CAT service bulletin out on this. It could also be the Injection Actuation Pressure Sensor or the Atmosphere Pressure Sensor starting to fail. Both sensors are 5 volt and share the same signal wire from the engine ECM.
Steve
30
Technical Support / Air Solenoid and Fuel Line Replacement
« Last post by Michael Turnipseed on June 13, 2024, 08:25:49 PM »
Hi there
Been dealing with a saggy driver side when parked. I’ve read numerous threads looking for the solution, last being water in the system ‘condensation’ unfortunately I’ve got no drains off my two stacked tanks behind drivers slide. Blew air out in service bay, turned on leveling system manually so I could raise front high. Over a six day period I’ve measured the height no change two days after that driver side started coming down 1/2” per day. Every day I’ve checked both sides with no change on passenger side until today, up a 1/2” . Have had no drastic temp changes in SW Washington to cause that change so.. is there a check not holding on the leveling valve?
2nd I’ve seen several posts about changing the fuel line from the secondary filter to the engine, I’ve found all the parts list and info to do it , it’s the why. Tried to find it in the ask Dave pages bu never came upon the why just that it seem to make the busses run better. Is it the wrong type of hose?
Thanks Michael
Pages: 1 2 [3] 4 5 ... 10