Visit our BAC Favorite Places Web Page

Author Topic: Kwikee Super Slide II Power slide (basement storage) not working  (Read 530 times)

Kevin Patchen

  • BAC Member
  • *
  • Posts: 23
  • Thanked: 3 times
Kwikee Super Slide II Power slide (basement storage) not working
« on: November 06, 2018, 03:39:44 PM »
I have a 2008 Beaver Patriot Thunder.
In my storage bays I have Kwikee Super Slide II see attachment (forward bay and aft bay) both have swithches on the inside of the storage door.  They were originally designed to have remote control for opperation.  Monaco added the switches to eliminate the remote.  Currently both of my slides are not working and both stop working at the same time. There is power to the control box on the forward side of each slide.  I looked high and low for the fuse but was unsuccessful. But if there is power at the contol box I say the lack of power isn't the problem. There is no power at the switchs on the doors.

Any ideas?


Kevin Patchen
2008 Beaver Patriot Thunder 40' Concord IV
525hp Cat C-13
2016 Jeep Wrangler, Blue Ox towing package

Mike Humble

  • BAC Member
  • *
  • Posts: 106
  • Thanked: 24 times
  • BAC Past President 2014-2018
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #1 on: November 06, 2018, 04:44:29 PM »
Sometimes mine are erratic.  Try opening DS doors and send slides that way.
Mike
2008 Marquis 45' Cat C-15 600hp

Kevin Patchen

  • BAC Member
  • *
  • Posts: 23
  • Thanked: 3 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #2 on: November 07, 2018, 02:26:02 AM »
That didn’t help nothing working. ??
Kevin Patchen
2008 Beaver Patriot Thunder 40' Concord IV
525hp Cat C-13
2016 Jeep Wrangler, Blue Ox towing package

Steve Huber Co-Admin

  • Administrator Group
  • *
  • Posts: 2000
  • Thanked: 1106 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #3 on: November 07, 2018, 05:18:30 AM »
Kevin,
I don't have an electrical diagram but would suspect the switches are providing ground to the motors. If the center pole of the switch is tied to ground and the other 2 terminals are open in the quiescent state, that is the configuration. The likelihood of problems in both motors seems remote (no pun intended). If you don't have ground at the switchs' center pole (and no 12 v either) but do have 12v at the motors, you may want to try grounding one of the switch terminals to see if the motor runs. That would indicate a lost ground to the switches.
Steve
Steve
2015-          07 Contessa Bayshore C9,  400 hp
2013-2015: 00 Marquis Tourmaline, C12, 425 hp
2005-2013: 01 Contessa Naples, 3126B, 330 hp

Kevin Patchen

  • BAC Member
  • *
  • Posts: 23
  • Thanked: 3 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #4 on: November 07, 2018, 04:20:31 PM »
Here is the wiring diagram attached
Kevin Patchen
2008 Beaver Patriot Thunder 40' Concord IV
525hp Cat C-13
2016 Jeep Wrangler, Blue Ox towing package

Steve Huber Co-Admin

  • Administrator Group
  • *
  • Posts: 2000
  • Thanked: 1106 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #5 on: November 07, 2018, 05:06:58 PM »
Kevin,
If there is 12v at the controller, the mini-breaker in the rear run box is OK. You may not see any voltage at the  switches since all three pins are connected to the controller. Since both trays stopped working they are probably sharing something. I'd suspect possibly a faulty ground connection. The diagram shows an 8 awg white wire running to gnd from the controller. Check to see if it is intact and making a good connection to both controllers.  You may also want to check the limit switches and verify that they open when the tray is moved (they should normally be closed, providing a gnd signal). Also, operate the switches and see what voltage you see on switch contacts.
Steve
Steve
2015-          07 Contessa Bayshore C9,  400 hp
2013-2015: 00 Marquis Tourmaline, C12, 425 hp
2005-2013: 01 Contessa Naples, 3126B, 330 hp

Kevin Patchen

  • BAC Member
  • *
  • Posts: 23
  • Thanked: 3 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #6 on: November 08, 2018, 06:06:34 PM »
Thank you Steve
Yesterday both slide trays started to work again.?????  During my investigation while using a test light checking for power at the back engine circuit panel (photo attached) I noted that at all the main power supply lugs at the bottom of the panel had a good strong bright light except the far left three. (they had light but very faint) The front run plate double chassis battery stud, chassis Batt Switch, and the Domestic Batt SW.  The 150 amp thermal breaker directly above the chassis Batt Switch is broken (reset switch) and can not be reset. (ordered new one) But I do think that's the problem. After the slides started working again the three terminals have good strong light now??? Today I'm checking all the connections at the disconnect switch's at the battery.  Any other Ideas?
Kevin Patchen
2008 Beaver Patriot Thunder 40' Concord IV
525hp Cat C-13
2016 Jeep Wrangler, Blue Ox towing package

Steve Huber Co-Admin

  • Administrator Group
  • *
  • Posts: 2000
  • Thanked: 1106 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #7 on: November 08, 2018, 07:50:04 PM »
Kevin,
The trays are on a 40A breaker so draw considerable current. Even tho you measured 12v at the tray controllers, I suspect that when you attempted to run them, the voltage dropped significantly due to the poor connections in the rear bay. Make sure all the large nuts in the bay holding the high current battery cables are tight. Be sure to check that there is no voltage present after turning off the battery disconect switches (both of them) before poking around with a socket driver. An arc can do untold damage.
[I had what I thought was an alternator problem (varying battery voltage) but found it was due to one of the large nuts being slightly loose in the battery bay].
Steve
« Last Edit: November 08, 2018, 07:57:04 PM by Steve Huber Co-Admin »
Steve
2015-          07 Contessa Bayshore C9,  400 hp
2013-2015: 00 Marquis Tourmaline, C12, 425 hp
2005-2013: 01 Contessa Naples, 3126B, 330 hp

Kevin Patchen

  • BAC Member
  • *
  • Posts: 23
  • Thanked: 3 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #8 on: November 09, 2018, 03:26:36 AM »
Were did you see the info on the 40amp breaker.
I’m not seeing it?
Kevin
Kevin Patchen
2008 Beaver Patriot Thunder 40' Concord IV
525hp Cat C-13
2016 Jeep Wrangler, Blue Ox towing package

Steve Huber Co-Admin

  • Administrator Group
  • *
  • Posts: 2000
  • Thanked: 1106 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #9 on: November 09, 2018, 05:15:44 AM »
On the  diagram, look at the 12v feed from the area near the solenoids.
Steve
Steve
2015-          07 Contessa Bayshore C9,  400 hp
2013-2015: 00 Marquis Tourmaline, C12, 425 hp
2005-2013: 01 Contessa Naples, 3126B, 330 hp

Kevin Patchen

  • BAC Member
  • *
  • Posts: 23
  • Thanked: 3 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #10 on: November 20, 2018, 05:33:15 AM »
Problem solved.
The chassis battery’s have ran down and the voltage dropped to 10.9v. The slides are operational.once batterys were charged. We have been parked for the last two months.. I started the coach three weeks ago but for some reason the inverter isn’t charging the battery even though the Magnum panel says Absorbing charge @ 12.8v.
Cleaning all chassis battery connections to see if that will resolve the problem. Any other ideas.
Kevin Patchen
2008 Beaver Patriot Thunder 40' Concord IV
525hp Cat C-13
2016 Jeep Wrangler, Blue Ox towing package

Steve Huber Co-Admin

  • Administrator Group
  • *
  • Posts: 2000
  • Thanked: 1106 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #11 on: November 20, 2018, 05:40:18 AM »
Check the Big Boy. See "Engine Won't Start" thread. Big Boy must be functional to charge chassis batteries from shore power via inverter.
Steve
Steve
2015-          07 Contessa Bayshore C9,  400 hp
2013-2015: 00 Marquis Tourmaline, C12, 425 hp
2005-2013: 01 Contessa Naples, 3126B, 330 hp

Kevin Patchen

  • BAC Member
  • *
  • Posts: 23
  • Thanked: 3 times
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #12 on: November 25, 2018, 04:01:32 PM »
Thank you all for the comments and advise!
I believe this has been a on going problem for quite some time. (Good and bad contact)
Some times my chassis battery changed and others it wouldn’t.
But never discharged enough just sitting for a couple of days.
What I have done is shut down all the power and removed the Big Boy relay.  I then disassembled the relay. There was not that much corrosion but a cosmoline layer over the lug contact surface. The contact disc had the same layer. I cleaned and scraped all contact surfaces, all seals were in good shape. I then reassembled and reinstalled the big boy. When I turned back on the chassis battery I heard the big boy snap closed which I have never heard before. I now have 13.5v across both main lugs of the big boy after allowing to change over night.
 I’m considering just changing out my Big boy relay just because of the possibility on failure.
Kevin Patchen
2008 Beaver Patriot Thunder 40' Concord IV
525hp Cat C-13
2016 Jeep Wrangler, Blue Ox towing package

Gerald Farris

  • Past President
  • Board Moderator
  • *
  • Posts: 1910
  • Thanked: 669 times
    • Farris Journey Across The USA
Re: Kwikee Super Slide II Power slide (basement storage) not working
« Reply #13 on: November 25, 2018, 11:01:04 PM »
Kevin,
If it is working properly after cleaning the contacts and the seals are OK, there is no reason to change it out for a new one. A new one can fail just as fast as your original one if the contacts were cleaned properly. If you replace every part that might fail on a motorhome, you will never finish if you do not go bankrupt first.

Gerald   
2002 Solitaire (2017 -  )
2000 Marquis, C12 (2004 - 2017)
1993 Patriot  (2000-2004)