Author Topic: Shurflo pump not working  (Read 356 times)

Fred Cook

  • BAC Member
  • *
  • Posts: 369
  • Thanked: 61 times
Shurflo pump not working
« on: August 01, 2020, 11:23:07 PM »
 OK, I have filled my tank many times in the past and the shurflo pump always works. Now it is running continuously and no water is being pumped.  It sounds like it is not getting any water from the tank. All settings are correct on the water panel.  Any ideals on what could be wrong?
Fred & Cindy
2002 Beaver Patriot Thunder 455, C12 CAT
Towing 2019 Chevy Equinox, AWD Diesel
South Central Missouri, US Army Retired

Bill Lampkin

  • BAC Member
  • *
  • Posts: 678
  • Thanked: 194 times
Re: Shurflo pump not working
« Reply #1 on: August 01, 2020, 11:41:43 PM »
If you have a auto tank fill switch, that will cause a no water situation. Check your fresh water auto tank fill switch.
2005 Patriot Thunder Lexington, 3 slides
40' tag axle (short wheelbase)
525 hp C13

"Liberty is not the power to do what one wants, but it is the desire to do what one can" J-P Sartre; inscription in base of Statue of Liberty

Fred Cook

  • BAC Member
  • *
  • Posts: 369
  • Thanked: 61 times
Re: Shurflo pump not working
« Reply #2 on: August 01, 2020, 11:57:50 PM »
Thanks, but I don’t have an auto fill switch option. I have filled my tank bunches of times with never a problem. I checked it out and it appears no water from the tank is reaching the pump.
Fred & Cindy
2002 Beaver Patriot Thunder 455, C12 CAT
Towing 2019 Chevy Equinox, AWD Diesel
South Central Missouri, US Army Retired

Bill Lampkin

  • BAC Member
  • *
  • Posts: 678
  • Thanked: 194 times
Re: Shurflo pump not working
« Reply #3 on: August 02, 2020, 12:03:23 AM »
Check the filter on the suction (tank) side of the pump. YOu could also disconnect the discharge side of the pump and put your thumb over it to block it, turn the pump on, that should get rid of any air in the pump.
2005 Patriot Thunder Lexington, 3 slides
40' tag axle (short wheelbase)
525 hp C13

"Liberty is not the power to do what one wants, but it is the desire to do what one can" J-P Sartre; inscription in base of Statue of Liberty
The following users thanked this post: Fred Cook

Fred Cook

  • BAC Member
  • *
  • Posts: 369
  • Thanked: 61 times
Re: Shurflo pump not working
« Reply #4 on: August 02, 2020, 12:42:55 AM »
Thanks Bill, I will give it a shot first thing in the morning.
Fred & Cindy
2002 Beaver Patriot Thunder 455, C12 CAT
Towing 2019 Chevy Equinox, AWD Diesel
South Central Missouri, US Army Retired

Keith Moffett

  • BAC Member
  • *
  • Posts: 1005
  • Thanked: 332 times
  • Every day is a blessing!
Re: Shurflo pump not working
« Reply #5 on: August 02, 2020, 10:02:50 AM »
Fred
We have had this same problem and I always foung the switch was set to fill the tank.  If you dont have the electric one then it must be on a knob.  If you checked that and still no flow then I would look to the pump as Bill says.  Perhaps it lost its prime.
I have been trying to recall if the Surflow has a built in check valve but that can also cause this.
2007 Patriot Thunder
45' C-13
2006 Explorer Ltd.
DW is Carol
Safe travels and
May God bless!

Eric Maclean

  • BAC Member
  • *
  • Posts: 243
  • Thanked: 81 times
  • Karen and I would like to wish you all happy trail
Re: Shurflo pump not working
« Reply #6 on: August 02, 2020, 03:07:34 PM »
Fred
I have had coaches where the city water connection check valve has gone bad and allowed the pump to suck air .
Try screwing a hose end plug into the city water connection and try your pump.
Good luck
Eric
1997 Patriot Yorktown
3126-B
2009 Chevy HHR
Roadmaster falcon tow bar
Demco Air Force one tow brake.

Fred Brooks

  • BAC Member
  • *
  • Posts: 925
  • Thanked: 460 times
  • RVIA Certified Luxury Technician 49 years, Retired
Re: Shurflo pump not working
« Reply #7 on: August 02, 2020, 11:09:33 PM »
   Hi Fred,
 If you have checked and rechecked all of the above suggestions, I would perform one last test. Remove the inlet side of the pump (the side with the strainer/filter. Is there water flowing from this line? If yes, reconnect and disconnect the outlet line and turn on the pump. If it just dribbles out you have a bad pump (broken diaphragms). If the pump changes sound and starts to pump water, you had air stuck in the pump that caused cavitation. The pump can't pump air so it gets stuck inside the pump until you let it out. Hope this helps, Fred
Fred & Cindy Brooks
2000 Marquis, Jasper
C-12 Wild Cat (U of A)
2014 Honda CRV
Proverbs 3: 5 & 6

Bill Sprague

  • BAC Member
  • *
  • Posts: 810
  • Thanked: 422 times
Re: Shurflo pump not working
« Reply #8 on: August 02, 2020, 11:23:07 PM »
Last time one of mine quit I went straight to the store and bought a new one.   Weeks later, while bored, I took the bad one apart and put it back together.  It worked perfectly.  Must have been some of the endless Quartzite grit that invades everything.

With the pump running, pull off the inlet.  Stick you finger there and you should feel suction.  If not, it broke!
Bill Sprague
Past Region 1 VP
2019 Tiffin Wayfarer 24TW
Past 3 year owner '15 PleasureWay Pursuit
Past 12 year owner of '04 Monterey w/Cummins ISC 350

Fred Cook

  • BAC Member
  • *
  • Posts: 369
  • Thanked: 61 times
Re: Shurflo pump not working
« Reply #9 on: August 03, 2020, 05:06:34 PM »
It works now! Just had to change out the filter. Thanks
Fred & Cindy
2002 Beaver Patriot Thunder 455, C12 CAT
Towing 2019 Chevy Equinox, AWD Diesel
South Central Missouri, US Army Retired